What’s Vulnerable › Vulnerabilities
CVE-2021-31822
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-24 · updated 2026-06-17
- Weakness: CWE-276
Description
When Octopus Tentacle is installed on a Linux operating system, the systemd service file permissions are misconfigured. This could lead to a local unprivileged user modifying the contents of the systemd service file to gain privileged access.
Affected products
- Octopus Deploy Octopus Tentacle: from 3.15.4 before 6.1.1116 — fixed in 6.1.1116
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Tentacle 6.1.1116. Check the vendor advisory for mitigations.
References
- https://advisories.octopus.com/adv/2021-11---Local-privilege-escalation-in-Octopus-Tentacle-%28CVE-2021-31822%29.2283732993.html
- https://advisories.octopus.com/adv/2021-11---Local-privilege-escalation-in-Octopus-Tentacle-%28CVE-2021-31822%29.2283732993.html
Get alerted when CVE-2021-31822 or the next vulnerability affects your stack