What’s Vulnerable › Vulnerabilities
CVE-2021-31828
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-06 · updated 2026-06-17
- Weakness: CWE-918
Description
An SSRF issue in Open Distro for Elasticsearch (ODFE) before 1.13.1.0 allows an existing privileged user to enumerate listening services or interact with configured resources via HTTP requests exceeding the Alerting plugin's intended scope.
Affected products
- Amazon Open Distro: before 1.13.1.0 — fixed in 1.13.1.0
How to fix
Upgrade to a fixed version: Amazon Open Distro 1.13.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/opendistro-for-elasticsearch/alerting/pull/353
- https://opendistro.github.io/for-elasticsearch-docs/version-history/
- https://rotem-bar.com/ssrf-in-open-distro-for-elasticsearch-cve-2021-31828
- https://github.com/opendistro-for-elasticsearch/alerting/pull/353
- https://opendistro.github.io/for-elasticsearch-docs/version-history/
- https://rotem-bar.com/ssrf-in-open-distro-for-elasticsearch-cve-2021-31828
Get alerted when CVE-2021-31828 or the next vulnerability affects your stack