What’s Vulnerable › Vulnerabilities
CVE-2021-31837: Out of bounds write vulnerability in McAfee GetSusp
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-09 · updated 2026-06-17
- Weakness: CWE-787
Description
Memory corruption vulnerability in the driver file component in McAfee GetSusp prior to 4.0.0 could allow a program being investigated on the local machine to trigger a buffer overflow in GetSusp, leading to the execution of arbitrary code, potentially triggering a BSOD.
Affected products
- McAfee,LLC McAfee GetSusp: before 4.0.0 — fixed in 4.0.0
How to fix
Upgrade to a fixed version: McAfee,LLC McAfee GetSusp 4.0.0. Check the vendor advisory for mitigations.
References
- https://kc.mcafee.com/corporate/index?page=content&id=SB10363
- https://kc.mcafee.com/corporate/index?page=content&id=SB10363
Get alerted when CVE-2021-31837 or the next vulnerability affects your stack