What’s Vulnerable › Vulnerabilities
CVE-2021-3185
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-01-26 · updated 2026-06-17
- Weakness: CWE-120
Description
A flaw was found in the gstreamer h264 component of gst-plugins-bad before v1.18.1 where when parsing a h264 header, an attacker could cause the stack to be smashed, memory corruption and possibly code execution.
Affected products
- Freedesktop Gst-Plugins-Bad: before 1.18.1 — fixed in 1.18.1
How to fix
Upgrade to a fixed version: Freedesktop Gst-Plugins-Bad 1.18.1. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1917192
- https://security.gentoo.org/glsa/202208-31
- https://bugzilla.redhat.com/show_bug.cgi?id=1917192
- https://security.gentoo.org/glsa/202208-31
Get alerted when CVE-2021-3185 or the next vulnerability affects your stack