What’s Vulnerable › Vulnerabilities
CVE-2021-31863
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-28 · updated 2026-06-17
- Weakness: CWE-20
Description
Insufficient input validation in the Git repository integration of Redmine before 4.0.9, 4.1.x before 4.1.3, and 4.2.x before 4.2.1 allows Redmine users to read arbitrary local files accessible by the application server process.
Affected products
- Debian Linux: 9.0
- Redmine: before 4.0.9; from 4.1.0 before 4.1.3; from 4.2.0 before 4.2.1 — fixed in 4.0.9, 4.1.3, 4.2.1
How to fix
Upgrade to a fixed version: Redmine 4.0.9, 4.1.3, 4.2.1. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2021/05/msg00013.html
- https://www.redmine.org/news/131
- https://www.redmine.org/projects/redmine/wiki/Security_Advisories
- https://lists.debian.org/debian-lts-announce/2021/05/msg00013.html
- https://www.redmine.org/news/131
- https://www.redmine.org/projects/redmine/wiki/Security_Advisories
Get alerted when CVE-2021-31863 or the next vulnerability affects your stack