What’s Vulnerable › Vulnerabilities
CVE-2021-3187
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-11 · updated 2026-06-17
- Weakness: CWE-276
Description
An issue was discovered in BeyondTrust Privilege Management for Mac before 5.7. An authenticated, unprivileged user can elevate privileges by running a malicious script (that executes as root from a temporary directory) during install time. (This applies to macOS before 10.15.5, or Security Update 2020-003 on Mojave and High Sierra, Later versions of macOS are not vulnerable.)
Affected products
- BeyondTrust Privilege Management For Mac: before 5.7 — fixed in 5.7
How to fix
Upgrade to a fixed version: BeyondTrust Privilege Management For Mac 5.7. Check the vendor advisory for mitigations.
References
- https://www.beyondtrust.com/docs/release-notes/privilege-management/index.htm
- https://www.beyondtrust.com/trust-center/security-advisories/bt22-06
- https://www.beyondtrust.com/docs/release-notes/privilege-management/index.htm
- https://www.beyondtrust.com/trust-center/security-advisories/bt22-06
Get alerted when CVE-2021-3187 or the next vulnerability affects your stack