What’s Vulnerable › Vulnerabilities
CVE-2021-31872
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-30 · updated 2026-06-17
- Weakness: CWE-190
Description
An issue was discovered in klibc before 2.0.9. Multiple possible integer overflows in the cpio command on 32-bit systems may result in a buffer overflow or other security impact.
Affected products
- Debian Linux: 9.0
- Klibc Project Klibc: before 2.0.9 — fixed in 2.0.9
How to fix
Upgrade to a fixed version: Klibc Project Klibc 2.0.9. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2021/04/30/1
- https://git.kernel.org/pub/scm/libs/klibc/klibc.git/commit/?id=9b1c91577aef7f2e72c3aa11a27749160bd278ff
- https://kernel.org/pub/linux/libs/klibc/2.0/
- https://lists.debian.org/debian-lts-announce/2021/06/msg00025.html
- https://lists.zytor.com/archives/klibc/2021-April/004593.html
- http://www.openwall.com/lists/oss-security/2021/04/30/1
- https://git.kernel.org/pub/scm/libs/klibc/klibc.git/commit/?id=9b1c91577aef7f2e72c3aa11a27749160bd278ff
- https://kernel.org/pub/linux/libs/klibc/2.0/
- https://lists.debian.org/debian-lts-announce/2021/06/msg00025.html
- https://lists.zytor.com/archives/klibc/2021-April/004593.html
Get alerted when CVE-2021-31872 or the next vulnerability affects your stack