What’s Vulnerable › Vulnerabilities
CVE-2021-31899
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-11 · updated 2026-06-17
Description
In JetBrains Code With Me bundled to the compatible IDEs before version 2021.1, the client could execute code in read-only mode.
Affected products
- JetBrains Code With Me: before 2021.1 — fixed in 2021.1
How to fix
Upgrade to a fixed version: JetBrains Code With Me 2021.1. Check the vendor advisory for mitigations.
References
- https://blog.jetbrains.com
- https://blog.jetbrains.com/blog/2021/05/07/jetbrains-security-bulletin-q1-2021/
- https://blog.jetbrains.com
- https://blog.jetbrains.com/blog/2021/05/07/jetbrains-security-bulletin-q1-2021/
Get alerted when CVE-2021-31899 or the next vulnerability affects your stack