What’s Vulnerable › Vulnerabilities
CVE-2021-31917
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-21 · updated 2026-06-17
- Weakness: CWE-287
Description
A flaw was found in Red Hat DataGrid 8.x (8.0.0, 8.0.1, 8.1.0 and 8.1.1) and Infinispan (10.0.0 through 12.0.0). An attacker could bypass authentication on all REST endpoints when DIGEST is used as the authentication method. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Affected products
- Infinispan-Server-Rest: from 10.0.0 before 11.0.12; from 12.0.0 before 12.1.4 — fixed in 11.0.12, 12.1.4
- RedHat Data Grid: 8.0.0, 8.0.1, 8.1.0, 8.1.1
How to fix
Upgrade to a fixed version: Infinispan-Server-Rest 11.0.12, 12.1.4. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/cve-2021-31917
- https://access.redhat.com/security/cve/cve-2021-31917
Get alerted when CVE-2021-31917 or the next vulnerability affects your stack