What’s Vulnerable › Vulnerabilities
CVE-2021-31926
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-30 · updated 2026-06-17
- Weakness: CWE-863
Description
AMP Application Deployment Service in CubeCoders AMP 2.1.x before 2.1.1.2 allows a remote, authenticated user to open ports in the local system firewall by crafting an HTTP(S) request directly to the applicable API endpoint (despite not having permission to make changes to the system's network configuration).
Affected products
- Cubecoders Amp: from 2.1.0 before 2.1.1.2 — fixed in 2.1.1.2
How to fix
Upgrade to a fixed version: Cubecoders Amp 2.1.1.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-31926 or the next vulnerability affects your stack