What’s Vulnerable › Vulnerabilities
CVE-2021-31997: python-postorius: postorius-permissions.sh used during %post allows local privilege escalation from postorius user to root
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-10 · updated 2026-06-17
- Weakness: CWE-59
Description
A UNIX Symbolic Link (Symlink) Following vulnerability in python-postorius of openSUSE Leap 15.2, Factory allows local attackers to escalate from users postorius or postorius-admin to root. This issue affects: openSUSE Leap 15.2 python-postorius version 1.3.2-lp152.1.2 and prior versions. openSUSE Factory python-postorius version 1.3.4-2.1 and prior versions.
Affected products
- openSUSE Python-Postorius: before 1.3.2-lp152.1.2; through 1.3.4-2.1 — fixed in 1.3.2-lp152.1.2
How to fix
Upgrade to a fixed version: openSUSE Python-Postorius 1.3.2-lp152.1.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-31997 or the next vulnerability affects your stack