What’s Vulnerable › Vulnerabilities
CVE-2021-31998: inn: %post calls user owned file allowing local privilege escalation to root
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-10 · updated 2026-06-17
- Weakness: CWE-276
Description
A Incorrect Default Permissions vulnerability in the packaging of inn of SUSE Linux Enterprise Server 11-SP3; openSUSE Backports SLE-15-SP2, openSUSE Leap 15.2 allows local attackers to escalate their privileges from the news user to root. This issue affects: SUSE Linux Enterprise Server 11-SP3 inn version inn-2.4.2-170.21.3.1 and prior versions. openSUSE Backports SLE-15-SP2 inn versions prior to 2.6.2. openSUSE Leap 15.2 inn versions prior to 2.6.2.
Affected products
- openSUSE Inn: through 2.4.2-170.21.3.1; before 2.6.2 — fixed in 2.6.2
How to fix
Upgrade to a fixed version: openSUSE Inn 2.6.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-31998 or the next vulnerability affects your stack