What’s Vulnerable › Vulnerabilities
CVE-2021-31999: Rancher: Privilege escalation vulnerability via malicious Connection header
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-15 · updated 2026-06-17
- Weakness: CWE-807
Description
A Reliance on Untrusted Inputs in a Security Decision vulnerability in Rancher allows users in the cluster to act as others users in the cluster by forging the "Impersonate-User" or "Impersonate-Group" headers. This issue affects: Rancher versions prior to 2.5.9. Rancher versions prior to 2.4.16.
Affected products
- Rancher: before 2.4.16; from 2.5.0 before 2.5.9 — fixed in 2.4.16, 2.5.9
How to fix
Upgrade to a fixed version: Rancher 2.4.16, 2.5.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-31999 or the next vulnerability affects your stack