What’s Vulnerable › Vulnerabilities
CVE-2021-3200
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-18 · updated 2026-06-17
- Weakness: CWE-120
Description
Buffer overflow vulnerability in libsolv 2020-12-13 via the Solver * testcase_read(Pool *pool, FILE *fp, const char *testcase, Queue *job, char **resultp, int *resultflagsp function at src/testcase.c: line 2334, which could cause a denial of service
Affected products
- OpenSUSE libsolv: before 0.7.17 — fixed in 0.7.17
- Oracle Communications Cloud Native Core Policy: 1.15.0
How to fix
Upgrade to a fixed version: OpenSUSE libsolv 0.7.17. Check the vendor advisory for mitigations.
References
- https://github.com/openSUSE/libsolv/issues/416
- https://github.com/yangjiageng/PoC/blob/master/libsolv-PoCs/PoC-testcase_read-2334
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://github.com/openSUSE/libsolv/issues/416
- https://github.com/yangjiageng/PoC/blob/master/libsolv-PoCs/PoC-testcase_read-2334
- https://www.oracle.com/security-alerts/cpuapr2022.html
Get alerted when CVE-2021-3200 or the next vulnerability affects your stack