What’s Vulnerable › Vulnerabilities
CVE-2021-32025
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-10 · updated 2026-06-17
- Weakness: CWE-368
Description
An elevation of privilege vulnerability in the QNX Neutrino Kernel of affected versions of QNX Software Development Platform version(s) 6.4.0 to 7.0, QNX Momentics all 6.3.x versions, QNX OS for Safety versions 1.0.0 to 1.0.2, QNX OS for Safety versions 2.0.0 to 2.0.1, QNX for Medical versions 1.0.0 to 1.1.1, and QNX OS for Medical version 2.0.0 could allow an attacker to potentially access data, modify behavior, or permanently crash the system.
Affected products
- BlackBerry Qnx Momentics: 6.3.0, 6.3.2
- BlackBerry Qnx Os For Medical: from 1.0 before 1.1.2; 2.0.0 — fixed in 1.1.2
- BlackBerry Qnx Os For Safety: from 1.0.0 before 1.0.3; from 2.0.0 before 2.0.2 — fixed in 1.0.3, 2.0.2
- BlackBerry QNX Software Development Platform (SDP): from 6.4.0 through 7.0
How to fix
Upgrade to a fixed version: BlackBerry Qnx Os For Medical 1.1.2; BlackBerry Qnx Os For Safety 1.0.3, 2.0.2. Check the vendor advisory for mitigations.
References
- http://support.blackberry.com/kb/articleDetail?articleNumber=000090868
- http://support.blackberry.com/kb/articleDetail?articleNumber=000090868
Get alerted when CVE-2021-32025 or the next vulnerability affects your stack