What’s Vulnerable › Vulnerabilities
CVE-2021-32027
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-01 · updated 2026-06-17
- Weakness: CWE-190
Description
A flaw was found in postgresql in versions before 13.3, before 12.7, before 11.12, before 10.17 and before 9.6.22. While modifying certain SQL array values, missing bounds checks let authenticated database users write arbitrary bytes to a wide area of server memory. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Affected products
- PostgreSQL: from 9.6.0 before 9.6.22; from 10.0 before 10.17; from 11.0 before 11.12; from 12.0 before 12.7; from 13.0 before 13.3 — fixed in 10.17, 11.12, 12.7, 13.3, 9.6.22
- Red Hat Enterprise Linux: 7.0, 8.0
- Red Hat JBoss EAP: 7.0.0
- RedHat Software Collections: all versions
How to fix
Upgrade to a fixed version: PostgreSQL 10.17, 11.12, 12.7, 13.3. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1956876
- https://security.gentoo.org/glsa/202211-04
- https://security.netapp.com/advisory/ntap-20210713-0004/
- https://www.postgresql.org/support/security/CVE-2021-32027/
- https://bugzilla.redhat.com/show_bug.cgi?id=1956876
- https://security.gentoo.org/glsa/202211-04
- https://security.netapp.com/advisory/ntap-20210713-0004/
- https://www.postgresql.org/support/security/CVE-2021-32027/
Get alerted when CVE-2021-32027 or the next vulnerability affects your stack