What’s Vulnerable › Vulnerabilities
CVE-2021-32028
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-11 · updated 2026-06-17
- Weakness: CWE-200
Description
A flaw was found in postgresql. Using an INSERT ... ON CONFLICT ... DO UPDATE command on a purpose-crafted table, an authenticated database user could read arbitrary bytes of server memory. The highest threat from this vulnerability is to data confidentiality.
Affected products
- PostgreSQL: from 9.6.0 before 9.6.22; from 10.0 before 10.17; from 11.0 before 11.12; from 12.0 before 12.7; from 13.0 before 13.3 — fixed in 10.17, 11.12, 12.7, 13.3, 9.6.22
How to fix
Upgrade to a fixed version: PostgreSQL 10.17, 11.12, 12.7, 13.3. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1956877
- https://security.gentoo.org/glsa/202211-04
- https://security.netapp.com/advisory/ntap-20211112-0003/
- https://www.postgresql.org/support/security/CVE-2021-32028
- https://bugzilla.redhat.com/show_bug.cgi?id=1956877
- https://security.gentoo.org/glsa/202211-04
- https://security.netapp.com/advisory/ntap-20211112-0003/
- https://www.postgresql.org/support/security/CVE-2021-32028
Get alerted when CVE-2021-32028 or the next vulnerability affects your stack