What’s Vulnerable › Vulnerabilities
CVE-2021-32029
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-08 · updated 2026-06-17
- Weakness: CWE-200
Description
A flaw was found in postgresql. Using an UPDATE ... RETURNING command on a purpose-crafted table, an authenticated database user could read arbitrary bytes of server memory. The highest threat from this vulnerability is to data confidentiality.
Affected products
- PostgreSQL: from 11.0 before 11.12; from 12.0 before 12.7; from 13.0 before 13.3 — fixed in 11.12, 12.7, 13.3
- Red Hat JBoss EAP: 7.0.0
How to fix
Upgrade to a fixed version: PostgreSQL 11.12, 12.7, 13.3. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1956883
- https://security.netapp.com/advisory/ntap-20211112-0003/
- https://www.postgresql.org/support/security/CVE-2021-32029/
- https://bugzilla.redhat.com/show_bug.cgi?id=1956883
- https://security.netapp.com/advisory/ntap-20211112-0003/
- https://www.postgresql.org/support/security/CVE-2021-32029/
Get alerted when CVE-2021-32029 or the next vulnerability affects your stack