What’s Vulnerable › Vulnerabilities
CVE-2021-32036: Denial of Service and Data Integrity vulnerability in features command
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-04 · updated 2026-06-17
- Weakness: CWE-770
Description
An authenticated user without any specific authorizations may be able to repeatedly invoke the features command where at a high volume may lead to resource depletion or generate high lock contention. This may result in denial of service and in rare cases could result in id field collisions. This issue affects MongoDB Server v5.0 versions prior to and including 5.0.3; MongoDB Server v4.4 versions prior to and including 4.4.9; MongoDB Server v4.2 versions prior to and including 4.2.16 and MongoDB Server v4.0 versions prior to and including 4.0.28
Affected products
- MongoDB: from 2.0.0 before 4.2.18; from 4.4.0 before 4.4.10; from 5.0.0 before 5.0.4 — fixed in 4.2.18, 4.4.10, 5.0.4
How to fix
Upgrade to a fixed version: MongoDB 4.2.18, 4.4.10, 5.0.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-32036 or the next vulnerability affects your stack