What’s Vulnerable › Vulnerabilities

CVE-2021-32050: Some MongoDB Drivers may publish events containing authentication-related data to a command listener configured by an application

Description

Some MongoDB Drivers may erroneously publish events containing authentication-related data to a command listener configured by an application. The published events may contain security-sensitive data when specific authentication-related commands are executed. Without due care, an application may inadvertently expose this sensitive information, e.g., by writing it to a log file. This issue only arises if an application enables the command listener feature (this is not enabled by default). This issue affects the MongoDB C Driver 1.0.0 prior to 1.17.7, MongoDB PHP Driver 1.0.0 prior to 1.9.2, MongoDB Swift Driver 1.0.0 prior to 1.1.1, MongoDB Node.js Driver 3.6 prior to 3.6.10, MongoDB Node.js Driver 4.0 prior to 4.17.0 and MongoDB Node.js Driver 5.0 prior to 5.8.0. This issue also affects users of the MongoDB C++ Driver dependent on the C driver 1.0.0 prior to 1.17.7 (C++ driver prior to 3.7.0).

Affected products

How to fix

Upgrade to a fixed version: MongoDB C++ 1.17.7; MongoDB C# Driver 1.17.7; MongoDB Node.Js 3.6.10, 4.17.0, 5.8.0; MongoDB PHP Driver 1.9.2; MongoDB Swift Driver 1.1.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-32050 or the next vulnerability affects your stack