What’s Vulnerable › Vulnerabilities

CVE-2021-32062

Description

MapServer before 7.0.8, 7.1.x and 7.2.x before 7.2.3, 7.3.x and 7.4.x before 7.4.5, and 7.5.x and 7.6.x before 7.6.3 does not properly enforce the MS_MAP_NO_PATH and MS_MAP_PATTERN restrictions that are intended to control the locations from which a mapfile may be loaded (with MapServer CGI).

Affected products

How to fix

Upgrade to a fixed version: MapServer 7.0.8, 7.2.3, 7.4.5, 7.6.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-32062 or the next vulnerability affects your stack