What’s Vulnerable › Vulnerabilities
CVE-2021-32075
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-24 · updated 2026-06-17
- Weakness: CWE-502
Description
Re-Logic Terraria before 1.4.2.3 performs Insecure Deserialization.
Affected products
- Re-Logic Terraria: before 1.4.2.3 — fixed in 1.4.2.3
How to fix
Upgrade to a fixed version: Re-Logic Terraria 1.4.2.3. Check the vendor advisory for mitigations.
References
- https://store.steampowered.com/news/app/105600/view/3062989030626131236
- https://terraria.fandom.com/wiki/1.4.2.3
- https://twitter.com/relogicgames
- https://vuln.ryotak.me/advisories/42
- https://store.steampowered.com/news/app/105600/view/3062989030626131236
- https://terraria.fandom.com/wiki/1.4.2.3
- https://twitter.com/relogicgames
- https://vuln.ryotak.me/advisories/42
Get alerted when CVE-2021-32075 or the next vulnerability affects your stack