What’s Vulnerable › Vulnerabilities
CVE-2021-32268
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-20 · updated 2026-06-17
- Weakness: CWE-787
Description
Buffer overflow vulnerability in function gf_fprintf in os_file.c in gpac before 1.0.1 allows attackers to execute arbitrary code. The fixed version is 1.0.1.
Affected products
- GPAC: before 1.0.1 — fixed in 1.0.1
How to fix
Upgrade to a fixed version: GPAC 1.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/gpac/gpac/commit/388ecce75d05e11fc8496aa4857b91245007d26e
- https://github.com/gpac/gpac/issues/1587
- https://github.com/gpac/gpac/commit/388ecce75d05e11fc8496aa4857b91245007d26e
- https://github.com/gpac/gpac/issues/1587
Get alerted when CVE-2021-32268 or the next vulnerability affects your stack