What’s Vulnerable › Vulnerabilities
CVE-2021-32305
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 87.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-18 · updated 2026-06-17
- Weakness: CWE-78
Description
WebSVN before 2.6.1 allows remote attackers to execute arbitrary commands via shell metacharacters in the search parameter.
Affected products
- websvn: before 2.6.1 — fixed in 2.6.1
How to fix
Upgrade to a fixed version: websvn 2.6.1. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/163225/Websvn-2.6.0-Remote-Code-Execution.html
- https://github.com/websvnphp/websvn/pull/142
- http://packetstormsecurity.com/files/163225/Websvn-2.6.0-Remote-Code-Execution.html
- https://github.com/websvnphp/websvn/pull/142
Get alerted when CVE-2021-32305 or the next vulnerability affects your stack