What’s Vulnerable › Vulnerabilities
CVE-2021-32472
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-11 · updated 2026-06-17
- Weakness: CWE-862
Description
Teachers exporting a forum in CSV format could receive a CSV of forums from all courses in some circumstances. Moodle versions 3.10 to 3.10.3, 3.9 to 3.9.6 and 3.8 to 3.8.8 are affected.
Affected products
- Moodle: from 3.8.0 before 3.8.9; from 3.9.0 before 3.9.7; from 3.10.0 before 3.10.4 — fixed in 3.10.4, 3.8.9, 3.9.7
How to fix
Upgrade to a fixed version: Moodle 3.10.4, 3.8.9, 3.9.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-32472 or the next vulnerability affects your stack