What’s Vulnerable › Vulnerabilities
CVE-2021-32474
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-11 · updated 2026-06-17
- Weakness: CWE-89
Description
An SQL injection risk existed on sites with MNet enabled and configured, via an XML-RPC call from the connected peer host. Note that this required site administrator access or access to the keypair. Moodle 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 and earlier unsupported versions are affected.
Affected products
- Moodle: before 3.5.18; from 3.8.0 before 3.8.9; from 3.9.0 before 3.9.7; from 3.10.0 before 3.10.4 — fixed in 3.10.4, 3.5.18, 3.8.9, 3.9.7
How to fix
Upgrade to a fixed version: Moodle 3.10.4, 3.5.18, 3.8.9, 3.9.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-32474 or the next vulnerability affects your stack