What’s Vulnerable › Vulnerabilities

CVE-2021-32478

Description

The redirect URI in the LTI authorization endpoint required extra sanitizing to prevent reflected XSS and open redirect risks. Moodle versions 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8 and earlier unsupported versions are affected.

Affected products

How to fix

Upgrade to a fixed version: Moodle 3.10.4, 3.8.9, 3.9.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-32478 or the next vulnerability affects your stack