What’s Vulnerable › Vulnerabilities
CVE-2021-32590
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-04 · updated 2026-06-17
- Weakness: CWE-89
Description
Multiple improper neutralization of special elements used in an SQL command vulnerabilities in FortiPortal 6.0.0 through 6.0.4, 5.3.0 through 5.3.5, 5.2.0 through 5.2.5, and 4.2.2 and earlier may allow an attacker with regular user's privileges to execute arbitrary commands on the underlying SQL database via specifically crafted HTTP requests.
Affected products
- Fortinet FortiPortal: from 3.2.0 through 3.2.2; from 4.0.0 through 4.0.4; from 4.1.0 through 4.1.2; from 4.2.0 through 4.2.4; from 5.0.0 through 5.0.3; from 5.1.0 through 5.1.2 — fixed in 5.2.6, 5.3.6, 6.0.5
How to fix
Upgrade to a fixed version: Fortinet FortiPortal 5.2.6, 5.3.6, 6.0.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-32590 or the next vulnerability affects your stack