What’s Vulnerable › Vulnerabilities
CVE-2021-32619: Static imports inside dynamically imported modules do not adhere to permission checks
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-28 · updated 2026-06-17
- Weakness: CWE-285
Description
Deno is a runtime for JavaScript and TypeScript that uses V8 and is built in Rust. In Deno versions 1.5.0 to 1.10.1, modules that are dynamically imported through `import()` or `new Worker` might have been able to bypass network and file system permission checks when statically importing other modules. The vulnerability has been patched in Deno release 1.10.2.
Affected products
- denoland deno: from 1.5.0 before 1.10.2 — fixed in 1.10.2
How to fix
Upgrade to a fixed version: denoland deno 1.10.2. Check the vendor advisory for mitigations.
References
- https://github.com/denoland/deno/security/advisories/GHSA-xpwj-7v8q-mcgj
- https://github.com/denoland/deno/security/advisories/GHSA-xpwj-7v8q-mcgj
Get alerted when CVE-2021-32619 or the next vulnerability affects your stack