What’s Vulnerable › Vulnerabilities
CVE-2021-32632: CSRF allowing modification of commands, modules, banphrases through hidden iFrames
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-20 · updated 2026-06-17
- Weakness: CWE-352
Description
Pajbot is a Twitch chat bot. Pajbot versions prior to 1.52 are vulnerable to cross-site request forgery (CSRF). Hosters of the bot should upgrade to `v1.52` or `stable` to install the patch or, as a workaround, can add one modern dependency.
Affected products
- pajbot: before 1.52 — fixed in 1.52
How to fix
Upgrade to a fixed version: pajbot 1.52. Check the vendor advisory for mitigations.
References
- https://gist.github.com/Melonify/d8e5d70cdc1bebb871f72dc79d69ac60
- https://github.com/pajbot/pajbot/releases/tag/v1.52
- https://github.com/pajbot/pajbot/security/advisories/GHSA-wmfr-qrg4-qc3h
- https://gist.github.com/Melonify/d8e5d70cdc1bebb871f72dc79d69ac60
- https://github.com/pajbot/pajbot/releases/tag/v1.52
- https://github.com/pajbot/pajbot/security/advisories/GHSA-wmfr-qrg4-qc3h
Get alerted when CVE-2021-32632 or the next vulnerability affects your stack