What’s Vulnerable › Vulnerabilities
CVE-2021-32633: Remote Code Execution via traversal in TAL expressions
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-21 · updated 2026-06-17
- Weakness: CWE-22
Description
Zope is an open-source web application server. In Zope versions prior to 4.6 and 5.2, users can access untrusted modules indirectly through Python modules that are available for direct use. By default, only users with the Manager role can add or edit Zope Page Templates through the web, but sites that allow untrusted users to add/edit Zope Page Templates through the web are at risk from this vulnerability. The problem has been fixed in Zope 5.2 and 4.6. As a workaround, a site administrator can restrict adding/editing Zope Page Templates through the web using the standard Zope user/role permission mechanisms. Untrusted users should not be assigned the Zope Manager role and adding/editing Zope Page Templates through the web should be restricted to trusted users only.
Affected products
- Plone CMS: through 4.3.20; from 5.0 through 5.2.4
- zopefoundation Zope: before 4.6; from 5.0 before 5.2 — fixed in 4.6, 5.2
How to fix
Upgrade to a fixed version: zopefoundation Zope 4.6, 5.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2021/05/21/1
- http://www.openwall.com/lists/oss-security/2021/05/22/1
- https://cyllective.com/blog/post/plone-authenticated-rce-cve-2021-32633/
- https://github.com/zopefoundation/Zope/commit/1f8456bf1f908ea46012537d52bd7e752a532c91
- https://github.com/zopefoundation/Zope/security/advisories/GHSA-5pr9-v234-jw36
- http://www.openwall.com/lists/oss-security/2021/05/21/1
- http://www.openwall.com/lists/oss-security/2021/05/22/1
- https://cyllective.com/blog/post/plone-authenticated-rce-cve-2021-32633/
- https://github.com/zopefoundation/Zope/commit/1f8456bf1f908ea46012537d52bd7e752a532c91
- https://github.com/zopefoundation/Zope/security/advisories/GHSA-5pr9-v234-jw36
Get alerted when CVE-2021-32633 or the next vulnerability affects your stack