What’s Vulnerable › Vulnerabilities
CVE-2021-32641: Reflected XSS when using flashMessages
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-04 · updated 2026-06-17
- Weakness: CWE-79
Description
auth0-lock is Auth0's signin solution. Versions of nauth0-lock before and including `11.30.0` are vulnerable to reflected XSS. An attacker can execute arbitrary code when the library's `flashMessage` feature is utilized and user input or data from URL parameters is incorporated into the `flashMessage` or the library's `languageDictionary` feature is utilized and user input or data from URL parameters is incorporated into the `languageDictionary`. The vulnerability is patched in version 11.30.1.
Affected products
- auth0 lock: before 11.30.1 — fixed in 11.30.1
How to fix
Upgrade to a fixed version: auth0 lock 11.30.1. Check the vendor advisory for mitigations.
References
- https://github.com/auth0/lock/commit/d139cf01c8234b07caf265e051f39d3eab08f7ed
- https://github.com/auth0/lock/releases/tag/v11.30.1
- https://github.com/auth0/lock/security/advisories/GHSA-jr3j-whm4-9wwm
- https://github.com/auth0/lock/commit/d139cf01c8234b07caf265e051f39d3eab08f7ed
- https://github.com/auth0/lock/releases/tag/v11.30.1
- https://github.com/auth0/lock/security/advisories/GHSA-jr3j-whm4-9wwm
Get alerted when CVE-2021-32641 or the next vulnerability affects your stack