What’s Vulnerable › Vulnerabilities
CVE-2021-32648: October CMS Improper Authentication
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-01-18
- EPSS: 91.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-26 · updated 2026-06-17
- Weakness: CWE-287
Description
octobercms in a CMS platform based on the Laravel PHP Framework. In affected versions of the october/system package an attacker can request an account password reset and then gain access to the account using a specially crafted request. The issue has been patched in Build 472 and v1.1.5.
Affected products
- octobercms october: from 1.1.1 before 1.1.5; 1.0.471 — fixed in 1.1.5
How to fix
Upgrade to a fixed version: octobercms october 1.1.5. Check the vendor advisory for mitigations.
References
- https://github.com/octobercms/library/commit/016a297b1bec55d2e53bc889458ed2cb5c3e9374
- https://github.com/octobercms/library/commit/5bd1a28140b825baebe6becd4f7562299d3de3b9
- https://github.com/octobercms/october/security/advisories/GHSA-mxr5-mc97-63rc
- https://github.com/octobercms/library/commit/016a297b1bec55d2e53bc889458ed2cb5c3e9374
- https://github.com/octobercms/library/commit/5bd1a28140b825baebe6becd4f7562299d3de3b9
- https://github.com/octobercms/october/security/advisories/GHSA-mxr5-mc97-63rc
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2021-32648
Get alerted when CVE-2021-32648 or the next vulnerability affects your stack