What’s Vulnerable › Vulnerabilities
CVE-2021-32657: Malicious user could break user administration page
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-01 · updated 2026-06-17
- Weakness: CWE-400
Description
Nextcloud Server is a Nextcloud package that handles data storage. In versions of Nextcloud Server prior to 10.0.11, 20.0.10, and 21.0.2, a malicious user may be able to break the user administration page. This would disallow administrators to administrate users on the Nextcloud instance. The vulnerability is fixed in versions 19.0.11, 20.0.10, and 21.0.2. As a workaround, administrators can use the OCC command line tool to administrate the Nextcloud users.
Affected products
- Nextcloud Server: before 19.0.11; from 20.0.0 before 20.0.10; from 21.0.0 before 21.0.2 — fixed in 19.0.11, 20.0.10, 21.0.2
How to fix
Upgrade to a fixed version: Nextcloud Server 19.0.11, 20.0.10, 21.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-fx62-q47f-f665
- https://hackerone.com/reports/1147611
- https://security.gentoo.org/glsa/202208-17
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-fx62-q47f-f665
- https://hackerone.com/reports/1147611
- https://security.gentoo.org/glsa/202208-17
Get alerted when CVE-2021-32657 or the next vulnerability affects your stack