What’s Vulnerable › Vulnerabilities
CVE-2021-32659: Automatic room upgrade handling can be used maliciously to bridge a room non-consentually
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-16 · updated 2026-06-17
- Weakness: CWE-306
Description
Matrix-appservice-bridge is the bridging service for the Matrix communication program's application services. In versions 2.6.0 and earlier, if a bridge has room upgrade handling turned on in the configuration (the `roomUpgradeOpts` key when instantiating a new `Bridge` instance.), any `m.room.tombstone` event it encounters will be used to unbridge the current room and bridge into the target room. However, the target room `m.room.create` event is not checked to verify if the `predecessor` field contains the previous room. This means that any malicious admin of a bridged room can repoint the traffic to a different room without the new room being aware. Versions 2.6.1 and greater are patched. As a workaround, disabling the automatic room upgrade handling can be done by removing the `roomUpgradeOpts` key from the `Bridge` class options.
Affected products
- matrix-org matrix-appservice-bridge: before 2.6.1 — fixed in 2.6.1
How to fix
Upgrade to a fixed version: matrix-org matrix-appservice-bridge 2.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/matrix-org/matrix-appservice-bridge/commit/b69e745584a34fcfd858df33e4631e420da07b9f
- https://github.com/matrix-org/matrix-appservice-bridge/releases/tag/2.6.1
- https://github.com/matrix-org/matrix-appservice-bridge/security/advisories/GHSA-35g4-qx3c-vjhx
- https://github.com/matrix-org/matrix-appservice-bridge/commit/b69e745584a34fcfd858df33e4631e420da07b9f
- https://github.com/matrix-org/matrix-appservice-bridge/releases/tag/2.6.1
- https://github.com/matrix-org/matrix-appservice-bridge/security/advisories/GHSA-35g4-qx3c-vjhx
Get alerted when CVE-2021-32659 or the next vulnerability affects your stack