What’s Vulnerable › Vulnerabilities
CVE-2021-32670: Reflected cross-site scripting issue in Datasette
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-07 · updated 2026-06-17
- Weakness: CWE-79
Description
Datasette is an open source multi-tool for exploring and publishing data. The `?_trace=1` debugging feature in Datasette does not correctly escape generated HTML, resulting in a [reflected cross-site scripting](https://owasp.org/www-community/attacks/xss/#reflected-xss-attacks) vulnerability. This vulnerability is particularly relevant if your Datasette installation includes authenticated features using plugins such as [datasette-auth-passwords](https://datasette.io/plugins/datasette-auth-passwords) as an attacker could use the vulnerability to access protected data. Datasette 0.57 and 0.56.1 both include patches for this issue. If you run Datasette behind a proxy you can workaround this issue by rejecting any incoming requests with `?_trace=` or `&_trace=` in their query string parameters.
Affected products
- simonw datasette: before 0.56.1 — fixed in 0.56.1
How to fix
Upgrade to a fixed version: simonw datasette 0.56.1. Check the vendor advisory for mitigations.
References
- https://datasette.io/plugins/datasette-auth-passwords
- https://github.com/simonw/datasette/issues/1360
- https://github.com/simonw/datasette/security/advisories/GHSA-xw7c-jx9m-xh5g
- https://owasp.org/www-community/attacks/xss/#reflected-xss-attacks
- https://pypi.org/project/datasette/
- https://datasette.io/plugins/datasette-auth-passwords
- https://github.com/simonw/datasette/issues/1360
- https://github.com/simonw/datasette/security/advisories/GHSA-xw7c-jx9m-xh5g
- https://owasp.org/www-community/attacks/xss/#reflected-xss-attacks
- https://pypi.org/project/datasette/
Get alerted when CVE-2021-32670 or the next vulnerability affects your stack