What’s Vulnerable › Vulnerabilities
CVE-2021-32674: Remote Code Execution via traversal in TAL expressions
- Severity: medium (CVSS 6.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-08 · updated 2026-06-17
- Weakness: CWE-22
Description
Zope is an open-source web application server. This advisory extends the previous advisory at https://github.com/zopefoundation/Zope/security/advisories/GHSA-5pr9-v234-jw36 with additional cases of TAL expression traversal vulnerabilities. Most Python modules are not available for using in TAL expressions that you can add through-the-web, for example in Zope Page Templates. This restriction avoids file system access, for example via the 'os' module. But some of the untrusted modules are available indirectly through Python modules that are available for direct use. By default, you need to have the Manager role to add or edit Zope Page Templates through the web. Only sites that allow untrusted users to add/edit Zope Page Templates through the web are at risk. The problem has been fixed in Zope 5.2.1 and 4.6.1. The workaround is the same as for https://github.com/zopefoundation/Zope/security/advisories/GHSA-5pr9-v234-jw36: A site administrator can restrict adding/editing Zope Page Templates through the web using the standard Zope user/role permission mechanisms. Untrusted users should not be assigned the Zope Manager role and adding/editing Zope Page Templates through the web should be restricted to trusted users only.
Affected products
- zopefoundation Zope: before 4.6.1; from 5.0.0 before 5.2.1 — fixed in 4.6.1, 5.2.1
How to fix
Upgrade to a fixed version: zopefoundation Zope 4.6.1, 5.2.1. Check the vendor advisory for mitigations.
References
- https://github.com/zopefoundation/Zope/commit/1d897910139e2c0b11984fc9b78c1da1365bec21
- https://github.com/zopefoundation/Zope/security/advisories/GHSA-5pr9-v234-jw36
- https://github.com/zopefoundation/Zope/security/advisories/GHSA-rpcg-f9q6-2mq6
- https://pypi.org/project/Zope/
- https://github.com/zopefoundation/Zope/commit/1d897910139e2c0b11984fc9b78c1da1365bec21
- https://github.com/zopefoundation/Zope/security/advisories/GHSA-5pr9-v234-jw36
- https://github.com/zopefoundation/Zope/security/advisories/GHSA-rpcg-f9q6-2mq6
- https://pypi.org/project/Zope/
Get alerted when CVE-2021-32674 or the next vulnerability affects your stack