What’s Vulnerable › Vulnerabilities
CVE-2021-32675: DoS vulnerability in Redis
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 16.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-04 · updated 2026-06-17
- Weakness: CWE-770
Description
Redis is an open source, in-memory database that persists on disk. When parsing an incoming Redis Standard Protocol (RESP) request, Redis allocates memory according to user-specified values which determine the number of elements (in the multi-bulk header) and size of each element (in the bulk header). An attacker delivering specially crafted requests over multiple connections can cause the server to allocate significant amount of memory. Because the same parsing mechanism is used to handle authentication requests, this vulnerability can also be exploited by unauthenticated users. The problem is fixed in Redis versions 6.2.6, 6.0.16 and 5.0.14. An additional workaround to mitigate this problem without patching the redis-server executable is to block access to prevent unauthenticated users from connecting to Redis. This can be done in different ways: Using network access control tools like firewalls, iptables, security groups, etc. or Enabling TLS and requiring users to authenticate using client side certificates.
Affected products
- Debian Linux: 10.0, 11.0
- Fedoraproject Fedora: 33, 34, 35
- NetApp Management Services For Element Software: all versions
- NetApp Management Services For Netapp Hci: all versions
- Oracle Corporation Communications Operations Monitor: 4.3, 4.4, 5.0
- Redis: from 5.0.0 before 5.0.14; from 6.0.0 before 6.0.16; from 6.2.0 before 6.2.6 — fixed in 5.0.14, 6.0.16, 6.2.6
How to fix
Upgrade to a fixed version: Redis 5.0.14, 6.0.16, 6.2.6. Check the vendor advisory for mitigations.
References
- https://github.com/redis/redis/commit/5674b0057ff2903d43eaff802017eddf37c360f8
- https://github.com/redis/redis/security/advisories/GHSA-f6pw-v9gw-v64p
- https://lists.apache.org/thread.html/ra603ff6e04549d7f290f61f9b11e2d2e4dba693b05ff053f4ec6bc47%40%3Cnotifications.geode.apache.org%3E
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HTYQ5ZF37HNGTZWVNJD3VXP7I6MEEF42/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VL5KXFN3ATM7IIM7Q4O4PWTSRGZ5744Z/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WR5WKJWXD4D6S3DJCZ56V74ESLTDQRAB/
- https://security.gentoo.org/glsa/202209-17
- https://security.netapp.com/advisory/ntap-20211104-0003/
- https://www.debian.org/security/2021/dsa-5001
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://github.com/redis/redis/commit/5674b0057ff2903d43eaff802017eddf37c360f8
- https://github.com/redis/redis/security/advisories/GHSA-f6pw-v9gw-v64p
Get alerted when CVE-2021-32675 or the next vulnerability affects your stack