What’s Vulnerable › Vulnerabilities

CVE-2021-32678: Ratelimit not applied on OCS API responses

Description

Nextcloud Server is a Nextcloud package that handles data storage. In versions prior to 19.0.13, 20.0.11, and 21.0.3, ratelimits are not applied to OCS API responses. This affects any OCS API controller (`OCSController`) using the `@BruteForceProtection` annotation. Risk depends on the installed applications on the Nextcloud Server, but could range from bypassing authentication ratelimits or spamming other Nextcloud users. The vulnerability is patched in versions 19.0.13, 20.0.11, and 21.0.3. No workarounds aside from upgrading are known to exist.

Affected products

How to fix

Upgrade to a fixed version: Nextcloud Server 19.0.13, 20.0.11, 21.0.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-32678 or the next vulnerability affects your stack