What’s Vulnerable › Vulnerabilities
CVE-2021-32680: Audit log is not properly logging unsetting of share expiration date
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-12 · updated 2026-06-17
- Weakness: CWE-778
Description
Nextcloud Server is a Nextcloud package that handles data storage. In versions priot to 19.0.13, 20.0.11, and 21.0.3, Nextcloud Server audit logging functionality wasn't properly logging events for the unsetting of a share expiration date. This event is supposed to be logged. This issue is patched in versions 19.0.13, 20.0.11, and 21.0.3.
Affected products
- Fedoraproject Fedora: 33, 34
- Nextcloud Server: before 19.0.13; from 20.0.0 before 20.0.11; from 21.0.0 before 21.0.3 — fixed in 19.0.13, 20.0.11, 21.0.3
How to fix
Upgrade to a fixed version: Nextcloud Server 19.0.13, 20.0.11, 21.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-fxpq-wq7c-vppf
- https://github.com/nextcloud/server/pull/27024
- https://hackerone.com/reports/1200810
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BVZS26RDME2DYTKET5AECRIZDFUGR2AZ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/J63NBVPR2AQCAWRNDOZSGRY5II4WS2CZ/
- https://security.gentoo.org/glsa/202208-17
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-fxpq-wq7c-vppf
- https://github.com/nextcloud/server/pull/27024
- https://hackerone.com/reports/1200810
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BVZS26RDME2DYTKET5AECRIZDFUGR2AZ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/J63NBVPR2AQCAWRNDOZSGRY5II4WS2CZ/
- https://security.gentoo.org/glsa/202208-17
Get alerted when CVE-2021-32680 or the next vulnerability affects your stack