What’s Vulnerable › Vulnerabilities
CVE-2021-32687: Integer overflow issue with intsets in Redis
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-04 · updated 2026-06-17
- Weakness: CWE-190
Description
Redis is an open source, in-memory database that persists on disk. An integer overflow bug affecting all versions of Redis can be exploited to corrupt the heap and potentially be used to leak arbitrary contents of the heap or trigger remote code execution. The vulnerability involves changing the default set-max-intset-entries configuration parameter to a very large value and constructing specially crafted commands to manipulate sets. The problem is fixed in Redis versions 6.2.6, 6.0.16 and 5.0.14. An additional workaround to mitigate the problem without patching the redis-server executable is to prevent users from modifying the set-max-intset-entries configuration parameter. This can be done using ACL to restrict unprivileged users from using the CONFIG SET command.
Affected products
- Debian Linux: 10.0, 11.0
- Fedoraproject Fedora: 33, 34, 35
- NetApp Management Services For Element Software: all versions
- NetApp Management Services For Netapp Hci: all versions
- Oracle Corporation Communications Operations Monitor: 4.3, 4.4, 5.0
- Redis: from 5.0.0 before 5.0.14; from 6.0.0 before 6.0.16; from 6.2.0 before 6.2.6 — fixed in 5.0.14, 6.0.16, 6.2.6
How to fix
Upgrade to a fixed version: Redis 5.0.14, 6.0.16, 6.2.6. Check the vendor advisory for mitigations.
References
- https://github.com/redis/redis/commit/a30d367a71b7017581cf1ca104242a3c644dec0f
- https://github.com/redis/redis/security/advisories/GHSA-m3mf-8x9w-r27q
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HTYQ5ZF37HNGTZWVNJD3VXP7I6MEEF42/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VL5KXFN3ATM7IIM7Q4O4PWTSRGZ5744Z/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WR5WKJWXD4D6S3DJCZ56V74ESLTDQRAB/
- https://security.gentoo.org/glsa/202209-17
- https://security.netapp.com/advisory/ntap-20211104-0003/
- https://www.debian.org/security/2021/dsa-5001
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://github.com/redis/redis/commit/a30d367a71b7017581cf1ca104242a3c644dec0f
- https://github.com/redis/redis/security/advisories/GHSA-m3mf-8x9w-r27q
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HTYQ5ZF37HNGTZWVNJD3VXP7I6MEEF42/
Get alerted when CVE-2021-32687 or the next vulnerability affects your stack