What’s Vulnerable › Vulnerabilities
CVE-2021-32702: Reflected XSS from the callback handler's error query parameter
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions before and including `1.4.1` are vulnerable to reflected XSS. An attacker can execute arbitrary code by providing an XSS payload in the `error` query parameter which is then processed by the callback handler as an error message. You are affected by this vulnerability if you are using `@auth0/nextjs-auth0` version `1.4.1` or lower **unless** you are using custom error handling that does not return the error message in an HTML response. Upgrade to version `1.4.1` to resolve. The fix adds basic HTML escaping to the error message and it should not impact your users.
Affected products
- auth0 nextjs-auth0: before 1.4.2 — fixed in 1.4.2
How to fix
Upgrade to a fixed version: auth0 nextjs-auth0 1.4.2. Check the vendor advisory for mitigations.
References
- https://github.com/auth0/nextjs-auth0/commit/6996e2528ceed98627caa28abafbc09e90163ccf
- https://github.com/auth0/nextjs-auth0/security/advisories/GHSA-954c-jjx6-cxv7
- https://www.npmjs.com/package/%40auth0/nextjs-auth0
- https://github.com/auth0/nextjs-auth0/commit/6996e2528ceed98627caa28abafbc09e90163ccf
- https://github.com/auth0/nextjs-auth0/security/advisories/GHSA-954c-jjx6-cxv7
- https://www.npmjs.com/package/%40auth0/nextjs-auth0
Get alerted when CVE-2021-32702 or the next vulnerability affects your stack