What’s Vulnerable › Vulnerabilities
CVE-2021-32706: (Authenticated) Remote Code Execution Possible in Web Interface 5.5
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 60.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-04 · updated 2026-06-17
- Weakness: CWE-94
Description
Pi-hole's Web interface provides a central location to manage a Pi-hole instance and review performance statistics. Prior to Pi-hole Web interface version 5.5.1, the `validDomainWildcard` preg_match filter allows a malicious character through that can be used to execute code, list directories, and overwrite sensitive files. The issue lies in the fact that one of the periods is not escaped, allowing any character to be used in its place. A patch for this vulnerability was released in version 5.5.1.
Affected products
- pi-hole: before 5.5.1 — fixed in 5.5.1
How to fix
Upgrade to a fixed version: pi-hole 5.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/pi-hole/AdminLTE/releases/tag/v5.5.1
- https://github.com/pi-hole/AdminLTE/security/advisories/GHSA-5cm9-6p3m-v259
- https://github.com/pi-hole/AdminLTE/releases/tag/v5.5.1
- https://github.com/pi-hole/AdminLTE/security/advisories/GHSA-5cm9-6p3m-v259
Get alerted when CVE-2021-32706 or the next vulnerability affects your stack