What’s Vulnerable › Vulnerabilities
CVE-2021-32710: Potential Session Hijacking in Shopware
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-24 · updated 2026-06-17
- Weakness: CWE-384
Description
Shopware is an open source eCommerce platform. Potential session hijacking of store customers in versions below 6.3.5.2. We recommend to update to the current version 6.3.5.2. You can get the update to 6.3.5.2 regularly via the Auto-Updater or directly via the download overview. For older versions of 6.1 and 6.2, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.
Affected products
- shopware: before 6.3.5.2 — fixed in 6.3.5.2
How to fix
Upgrade to a fixed version: shopware 6.3.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/shopware/platform/commit/010c0154bea57c1fca73277c7431d029db7a972e
- https://github.com/shopware/platform/security/advisories/GHSA-h9q8-5gv2-v6mg
- https://github.com/shopware/platform/commit/010c0154bea57c1fca73277c7431d029db7a972e
- https://github.com/shopware/platform/security/advisories/GHSA-h9q8-5gv2-v6mg
Get alerted when CVE-2021-32710 or the next vulnerability affects your stack