What’s Vulnerable › Vulnerabilities
CVE-2021-32712: Information leakage in Error Handler
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-24 · updated 2026-06-17
- Weakness: CWE-200
Description
Shopware is an open source eCommerce platform. Versions prior to 5.6.10 are vulnerable to system information leakage in error handling. Users are recommend to update to version 5.6.10. You can get the update to 5.6.10 regularly via the Auto-Updater or directly via the download overview.
Affected products
- shopware: from 5.0.0 before 5.6.10 — fixed in 5.6.10
How to fix
Upgrade to a fixed version: shopware 5.6.10. Check the vendor advisory for mitigations.
References
- https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-05-2021
- https://github.com/shopware/shopware/commit/dcb24eb5ec757c991b5a4e2ddced379e5820744d
- https://github.com/shopware/shopware/security/advisories/GHSA-9vxv-wpv4-f52p
- https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-05-2021
- https://github.com/shopware/shopware/commit/dcb24eb5ec757c991b5a4e2ddced379e5820744d
- https://github.com/shopware/shopware/security/advisories/GHSA-9vxv-wpv4-f52p
Get alerted when CVE-2021-32712 or the next vulnerability affects your stack