What’s Vulnerable › Vulnerabilities
CVE-2021-32714: Integer Overflow in Chunked Transfer-Encoding
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-07-07 · updated 2026-06-17
- Weakness: CWE-190
Description
hyper is an HTTP library for Rust. In versions prior to 0.14.10, hyper's HTTP server and client code had a flaw that could trigger an integer overflow when decoding chunk sizes that are too big. This allows possible data loss, or if combined with an upstream HTTP proxy that allows chunk sizes larger than hyper does, can result in "request smuggling" or "desync attacks." The vulnerability is patched in version 0.14.10. Two possible workarounds exist. One may reject requests manually that contain a `Transfer-Encoding` header or ensure any upstream proxy rejects `Transfer-Encoding` chunk sizes greater than what fits in 64-bit unsigned integers.
Affected products
- hyperium hyper: before 0.14.10 — fixed in 0.14.10
- Crates.Io Hyper: from 0.0.0-0 before 0.14.10 — fixed in 0.14.10
How to fix
Upgrade to a fixed version: hyperium hyper 0.14.10; Crates.Io Hyper 0.14.10. Check the vendor advisory for mitigations.
References
- https://github.com/hyperium/hyper/security/advisories/GHSA-5h46-h7hh-c6x9
- https://github.com/hyperium/hyper/security/advisories/GHSA-5h46-h7hh-c6x9
Get alerted when CVE-2021-32714 or the next vulnerability affects your stack