What’s Vulnerable › Vulnerabilities
CVE-2021-32718: Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) in RabbitMQ management UI
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-28 · updated 2026-06-17
- Weakness: CWE-80
Description
RabbitMQ is a multi-protocol messaging broker. In rabbitmq-server prior to version 3.8.17, a new user being added via management UI could lead to the user's bane being rendered in a confirmation message without proper `<script>` tag sanitization, potentially allowing for JavaScript code execution in the context of the page. In order for this to occur, the user must be signed in and have elevated permissions (other user management). The vulnerability is patched in RabbitMQ 3.8.17. As a workaround, disable `rabbitmq_management` plugin and use CLI tools for management operations and Prometheus and Grafana for metrics and monitoring.
Affected products
- VMware Tanzu RabbitMQ: before 3.8.17 — fixed in 3.8.17
- rabbitmq-server: before 3.8.17
How to fix
Upgrade to a fixed version: VMware Tanzu RabbitMQ 3.8.17. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2021/Dec/3
- https://github.com/rabbitmq/rabbitmq-server/pull/3028
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-c3hj-rg5h-2772
- http://seclists.org/fulldisclosure/2021/Dec/3
- https://github.com/rabbitmq/rabbitmq-server/pull/3028
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-c3hj-rg5h-2772
Get alerted when CVE-2021-32718 or the next vulnerability affects your stack