What’s Vulnerable › Vulnerabilities
CVE-2021-32719: Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) in RabbitMQ federation management plugin
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-28 · updated 2026-06-17
- Weakness: CWE-80
Description
RabbitMQ is a multi-protocol messaging broker. In rabbitmq-server prior to version 3.8.18, when a federation link was displayed in the RabbitMQ management UI via the `rabbitmq_federation_management` plugin, its consumer tag was rendered without proper <script> tag sanitization. This potentially allows for JavaScript code execution in the context of the page. The user must be signed in and have elevated permissions (manage federation upstreams and policies) for this to occur. The vulnerability is patched in RabbitMQ 3.8.18. As a workaround, disable the `rabbitmq_federation_management` plugin and use [CLI tools](https://www.rabbitmq.com/cli.html) instead.
Affected products
- VMware Tanzu RabbitMQ: before 3.8.18 — fixed in 3.8.18
- rabbitmq-server: before 3.8.18
How to fix
Upgrade to a fixed version: VMware Tanzu RabbitMQ 3.8.18. Check the vendor advisory for mitigations.
References
- https://github.com/rabbitmq/rabbitmq-server/pull/3122
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-5452-hxj4-773x
- https://herolab.usd.de/security-advisories/usd-2021-0011/
- https://github.com/rabbitmq/rabbitmq-server/pull/3122
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-5452-hxj4-773x
- https://herolab.usd.de/security-advisories/usd-2021-0011/
Get alerted when CVE-2021-32719 or the next vulnerability affects your stack