What’s Vulnerable › Vulnerabilities
CVE-2021-3273
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-02-25 · updated 2026-06-17
- Weakness: CWE-94
Description
Nagios XI below 5.7 is affected by code injection in the /nagiosxi/admin/graphtemplates.php component. To exploit this vulnerability, someone must have an admin user account in Nagios XI's web system.
Affected products
- Nagios XI: before 5.7 — fixed in 5.7
How to fix
Upgrade to a fixed version: Nagios XI 5.7. Check the vendor advisory for mitigations.
References
- https://gist.github.com/leommxj/93edce6f8572cefe79a3d7da4389374e
- https://www.nagios.com/downloads/nagios-xi/change-log/
- https://gist.github.com/leommxj/93edce6f8572cefe79a3d7da4389374e
- https://www.nagios.com/downloads/nagios-xi/change-log/
Get alerted when CVE-2021-3273 or the next vulnerability affects your stack