What’s Vulnerable › Vulnerabilities
CVE-2021-32735: Cross-site scripting (XSS) from field and configuration text displayed in the Panel
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-02 · updated 2026-06-17
- Weakness: CWE-80
Description
Kirby is a content management system. In Kirby CMS versions 3.5.5 and 3.5.6, the Panel's `ListItem` component (used in the pages and files section for example) displayed HTML in page titles as it is. This could be used for cross-site scripting (XSS) attacks. Malicious authenticated Panel users can escalate their privileges if they get access to the Panel session of an admin user. Visitors without Panel access can use the attack vector if the site allows changing site data from a frontend form. Kirby 3.5.7 patches the vulnerability. As a partial workaround, site administrators can protect against attacks from visitors without Panel access by validating or sanitizing provided data from the frontend form.
Affected products
- getkirby kirby: before 3.5.7 — fixed in 3.5.7
How to fix
Upgrade to a fixed version: getkirby kirby 3.5.7. Check the vendor advisory for mitigations.
References
- https://github.com/getkirby/kirby/releases/tag/3.5.7
- https://github.com/getkirby/kirby/security/advisories/GHSA-2f2w-349x-vrqm
- https://github.com/getkirby/kirby/releases/tag/3.5.7
- https://github.com/getkirby/kirby/security/advisories/GHSA-2f2w-349x-vrqm
Get alerted when CVE-2021-32735 or the next vulnerability affects your stack